sábado, 18 de febrero de 2017

Bloqueo de Publicidad Youtube desde Mikrotik Usando Layer 7

Bloqueo de Publicidad Youtube desde Mikrotik Usando Layer 7

Una manera de bloquear alguna publicidad intrusiva en youtube y de otras paginas.
Esto no es solucion final, es solo un ejemplo para testar, no los bloquea al 100 %. Las publicidades en adservice (google) actualmente negocian con el nuevo protocolo criptografíco TSL.

Otra y mejor opcion y solución es instalar Add-ons al navegador Google Chrome : uBlock Origin 



https://chrome.google.com/webstore/detail/ublock-origin/cjpalhdlnbpafiamejdnhcphjbkeiagm?hl=es


Versión del addons para Mozilla Firefox:


https://addons.mozilla.org/es/android/addon/ublock-origin/


/ip firewall layer7-protocol
add comment="" name=block-publicidad regexp="(doubleclick|google-analytics|googleadservices|googlesyndication)\.(net|com)"

En Mikrotik: Insertar el código en el terminal de Winbox.


/ip firewall layer7-protocol
add name=Lista_Blanca_Google regexp="(lh(3|4|5|6)|alt|chrome|download|tools|ssl|\
    safebrowsing|safebrowsing-cache|pack|omahaproxy|m|gweb-gettingstartedguide|d\
    l-ssl|dl|cros-omahaproxy|commondatastorage|storage|tools|www|accounts|chrome\
    os-ca|clients(1|2|3|4)|policies|alt[0-9]{1,2}|mtalk|fonts|url|news).(ggpht|g\
    static|1e100|googleusercontent|appspot|googleapis|youtube|google|gstatic)\\.\
    (com|pe).*\$"


add name=Exeption_Up_Down regexp="(up|down)load|log(off|in|out)|speedtest|wixmp|\
    .fbcdn.net|soloveo.com|unpkg.com|playerlimpitv.com|hls.limpi.tv|elcomercio|m\
    sauth|static|live|mail|inbox|about|blogspot|account|help|gstatic"


add name=ADS2 regexp="([a-zA-Z0-9]*)\?ads|popcash|2mdn|\
    clicksor|pubmatic|onclkds|onclikads|adnxs|adsnative|taboola|trafficfactory|a\
    dvertising^|terraclicks|onclickads|openx|amazon-adsystem|admedia|webclicktra\
    cer|adform|clickmngr|adsk2|adk2x|adpdx|pubcontent|pub-ad\\.tech|/(ads|adServ\
    e|adrotate|adnetwork|ads-iframe)/|pub-|(ads|adserver|epomads\\d)\\.|/pagead2\
    |/pagead/(aclk|ads)\\\?|ads|adserver|epomads\\d\\.|(googleads|adclick)\\.g\\\
    .|/qoe\?|/*_204\?\$image|/get_midroll_|/ptracking\\\?|googlesyndication^|/pa\
    gead^/|googleadservices^|doubleclick.net^|pagead2^|/pagead/(aclk|ads)\\\?|ro\
    tator\\.\\w+\\.(com|net|info)"





/ip firewall filter
add action=accept chain=forward comment="List_White_Google [https://support.goog\
    le.com/chrome/a/answer/6334001\?hl=es]" layer7-protocol=Lista_Blanca_Google
add action=accept chain=forward comment="Accept this is not advertising" \
    layer7-protocol=Exeption_Up_Down
add action=reject chain=forward comment=ADS2 layer7-protocol=ADS1 log-prefix=\
    "PUBLICIDAD BLOQUEADO" reject-with=icmp-admin-prohibited










==========================================================
La otra forma un ejemplo extraído de esta direccion : http://arg-wireless.com.ar/index.php?topic=1542.0

El contenido googleads.g.doubleclick.net hace referencia a las publicidades de Google Adsense y el contenido &ctier hace referencia a las publicidades de los videos de Youtube.


/ip firewall filter

add action=drop chain=forward comment="BLOCK PUBLICIDAD" content=\
    googleads.g.doubleclick.net dst-port=80 protocol=tcp
add action=drop chain=forward comment="BLOCK VIDEOS PUBLICITARIOS YOUTUBE" \
    content=&ctier dst-port=80 protocol=tcp

4 comentarios: